SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Evangelist GeekSupport's Avatar
    Join Date
    May 2002
    Location
    Southern California
    Posts
    408
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    (IE6 problem) typing url & hyperlink with cache_limiter off

    (IE 6 problem, maybe lower too)

    a little overview:

    Right now i have session.cache_limiter off so that users can click the back button after submitting a form.

    senario:

    i have an error checking method that checks if the user has permission to modify a form. if the user does not, it will set an error var (in a class) to be displayed on the screen when the page is reloaded. The error will look like "No permission to modify form #" where # is the form number

    problem:

    with session.cache_limiter on, if a user tried to change the url from, say, /index.php?action=edit&formid=3 to /index.php?action=edit&formid=5, the page would refresh with the appropriate error message.

    now, after disabling session.cache_limiter, users can freely click the back button without getting the "Page has Expired" error. But now if someone tries to change the url, it won't show the error messages unless s/he hits refresh.

    Above was if the user manually changed the url. Now, if s/he clicked a hyperlink which contained an invalid formid, the error will show up fine even with cache_limiter off.

    question:

    is there a way i can have both options: immediately show the error if typed in the address-bar and let users freely click the back/fwd button?

    What is the difference between clicking a hyperlink and typing it in the url? Is the browser told something different when clicking a hyperlink?

    note:

    having cache_limiter disabled works fine in netscape 4.8 and 7. i'm having trouble getting IE to recognize url "hacking" attempts.
    Last edited by GeekSupport; May 10, 2003 at 00:46.

  2. #2
    SitePoint Evangelist GeekSupport's Avatar
    Join Date
    May 2002
    Location
    Southern California
    Posts
    408
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hmm..i just changed my .htaccess to have php_value session.cache_limiter nocache and it seems like it is working. it's not giving "Page has Expired".

    [edit]
    that seems to have done the trick. pretty weird since that's supposed to be the php.ini default (right?). I dont have access to that since i'm using a hosted site.
    Last edited by GeekSupport; May 10, 2003 at 01:06.

  3. #3
    SitePoint Evangelist GeekSupport's Avatar
    Join Date
    May 2002
    Location
    Southern California
    Posts
    408
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    [edit2]
    nevermind, that didnt solve the problem. i still get "Page has expired"

    (the edit-button is giving me problems)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •