SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Thread: actionscripts

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    May 2003
    Location
    halifax
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    actionscripts

    hello,

    i am new at this flash thing. heres the situation. I have a looped from frame, say, 135 to 195 - i.e. the movie plays within these frames. I have written an action script to jump to frame 196 on a button click. simple so far. the trouble is once it reaches the 196th frame, the movie doesnt display anything even though there are clips and objects beyond it.

    i have been at it for hours and cant figure out why does it not display the clips beyond 196. help!

  2. #2
    SitePoint Wizard aaron.martone's Avatar
    Join Date
    Feb 2003
    Location
    Florida, USA
    Posts
    2,322
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    First of all. Wrong forum

    Source files would help if possible. I'm going ot assume you are using Flash MX since you havn't specified.

    The said "script" should look like

    Code:
    on(release){
       _root.gotoAndPlay(196);
    }
    Also, I can't understand your description. Do you refer to the "movie" as the root movie or a movieclip residing on the root level?

    If things are not displayed at frame 196 after the jump, make sure that there are frames in the layers so they have "room" to exist.

    ie, if you have 2 layers, and one is longer then the other, all objects on the shorter layer will disappear when it gets to the end of it's timeline.

  3. #3
    SitePoint Member
    Join Date
    May 2003
    Location
    halifax
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hi,

    i guess my old eyes couldnt make out the wrong forum. And thanx for the response.

    yes i am using flash MX. basically i want to build a main navigational page for my site in flash. and i have not used much action scripts at all. just started with them.

    i'll have to clear the basics about root movie and root level (i'm just 2 days old at this stuff). basicaly, i cant tell the difference.

    i do have layers (and stuff in the layers) after frame 196. i didnt have the "_root." part. I made the changes and it still wont display objects in frames after 196.

    if it is of help you might want to check is2.dal.ca/~catreya/ ..... the circle and star (if you could call it one) animates between frames 135 and 195. on a button click i want the head to jump to 196 and retain the "stuff" (upto frame 220) in the layers (and i have tons of them) but it blanks out.

  4. #4
    SitePoint Wizard aaron.martone's Avatar
    Join Date
    Feb 2003
    Location
    Florida, USA
    Posts
    2,322
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Your server seems down. Email me the .FLA file and I'll see what's up and then resend you the modified .FLA file. The problem with being new to Flash is that you don't quite know the terminology (a book or 2 will help immensely) Either the server is down or its exceptionally slow. Send the file my way and I'll see what I can do


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •