SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    Non-Member
    Join Date
    Apr 2013
    Posts
    41
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Google Displaying “Bad Request” On Searching A Keyword






    When I search for the keyword of my website over google, it displays “Bad Request” with the link to my website. Why is it displaying bad request? Have I done something wrong in the SEO? Please help me out! I’d really appreciate it!

  2. #2
    Mouse catcher silver trophy
    Stevie D's Avatar
    Join Date
    Mar 2006
    Location
    Yorkshire, UK
    Posts
    5,835
    Mentioned
    113 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by shamshadali View Post
    When I search for the keyword of my website over google, it displays “Bad Request” with the link to my website. Why is it displaying bad request? Have I done something wrong in the SEO? Please help me out! I’d really appreciate it!
    My guess would be that at some point, Google has tried to reach that page but has hit a 400 error (Bad request) due to some glitch or other, and that has somehow made its way into the index. Google does seem to be increasingly using its own interpretation in the page title rather than simply using the <title> tag given on the page, which isn't necessarily helpful. I would check your site logs, and as long as you haven't had a rash of errors with people being unable to access your site repeatedly or for long periods of time, it's one of those things that should clear itself up in time. You could try changing the <title> slightly to see if that triggers Google to update its index.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •