SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Thread: Alpha 4.1.0

  1. #1
    SitePoint Enthusiast
    Join Date
    Oct 2001
    Location
    Belgium - Antwerp
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Alpha 4.1.0

    Hi,

    I use MySQL 3.23 for building a webapp on top.

    The tool that I use to manage the database is DBTools. I like it, it's a good tool and is easy to use. I frequently visit mysql.com searching for updates. And indeed, there you had it.. 4.0 was in production and 4.1.0 Alpha developpement was also available.
    Now what did I do ?
    I downloaded the Alpha version, main reason : the use of subqueries. And it works perfectly !

    However..

    DBTools doesn't work anymore.. When trying to connect to my database I get an error message : Client does not support authentication protocol requested by server. Consider upgrading MySQL Client.
    I thought.. damm No support.. So I started looking for other Client GUI's.. like the MySQL Control Center, but I got the same error there.
    So I'm now forced to use the standard MySQL Client. Running my testing queries in script-files. I can manage I guess but I miss a GUI

    Someone out there knows one that works with the Alpha version and, if not, what are the alternatives .. f.e. I heard something about PostgresSQL.. would that be a better choice of database ? (+: subqueries, stored procedures, views, etc. - : slow ?)

    Any help would be greatly appreciated !

    Greettzz

  2. #2
    SitePoint Wizard silver trophy redemption's Avatar
    Join Date
    Sep 2001
    Location
    Singapore
    Posts
    5,269
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well if you're willing to wait, I suppose DBtools (haven't used it) will finally support a production version of MySQL that supports nested queries.

    I don't know of any client that specifically works with the alpha version, so sorry

    As for alternatives, consider PostgreSQL if you're on a UNIX or UNIX-like platform - not so good for Windows as yet because it's difficult to install (you need cygwin). You can also consider Sybase ASE, and MSSQL, though they are obviously not free.

    PostgreSQL supports nested queries, stored procedures, foreign key constraints, views and even inheritance. So do Sybase and MSSQL (not sure about inheritance though).

  3. #3
    SitePoint Enthusiast
    Join Date
    Oct 2001
    Location
    Belgium - Antwerp
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Update

    I think I discovered it has nothing to do with the version of MySQL.
    According to my opinion the reason lies within the domain of MySQL priveleges.

    I was installing the app at home one day and I noticed that DBTool DID work on the Alpha version. However, I could not connect properly to the server via JDBC for some reason.
    Trying to resolve that last problem I was reloading the priveleges, dumping them etc. afterwich DBTool suddenly didn't work anymore on MySQL.

    Now I can connect to MySQl directly but the failure of the JDBC connection is still a riddle for me. The whole priveleges system is somewhat vague and obscure to me at the moment.. time will resolve everything I guess...

    Anyway, thx for the reply !

    Greettzz


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •