SitePoint Sponsor

User Tag List

Results 1 to 16 of 16
  1. #1
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    death to IE 7 & 8 ;-)

    could please someone who has IE handy see if this page looks the same IE 7 8 as it does in all the other browsers? (I assume IE9 should look the same as moz & webkit? )

    http://mayacove.com/dev/rd_res/test_pg.html
    (I cannot test in IE until tomorrow morning..)

    thank you very much....

  2. #2
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    here,
    http://mayacove.com/dev/rd_res/test_pg_ie.html

    I load a stylesheet for IE7/8... does it work?

    thank you very much....

  3. #3
    SitePoint Mentor NightStalker-DNS's Avatar
    Join Date
    Jul 2004
    Location
    Cape Town, South Africa
    Posts
    2,880
    Mentioned
    48 Post(s)
    Tagged
    0 Thread(s)
    No, it does not look the same at all. It has none of the rounded corners or spacing

    Attached is a picture with Chrome and IE8 next to each other.

    IE.jpg

  4. #4
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    oh my gosh.. this means that using "rem" for padding doesn't work...

    following advice here,
    http://www.webdesignerdepot.com/2012...ve-typography/

    am using "rem" for font-size, instead of em.. thought I'd use it for padding & margins too.. I guess IE doesn't like it....

    I guess I need to go back to percentages for setting padding & margins for IE? (it looks like it works for font-sizes, though...)

    (but it looks like modernizr is working for all HTML5 stuff.....;-)

    thank you....

  5. #5
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    PS: it looks like rem works in IE 7/8 for font-sizes, but not for padding and margins....

    I have to redo all padding & margins, what a pain...

    so what is best, percentages or em?

    oh brother.....

    have my rd site ready, but can't publish b/c of IE 7/8 probs....;-(

  6. #6
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    ok, I took out all .rem ref's except for font-size and line-height...

    does it work in IE7/8 now?
    http://mayacove.com/dev/rd_res/test_pg_ie.html

    thank you very much....

  7. #7
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,996
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Hi Maya,

    Did you ever consider using Browser Shots?
    Basically, you can enter your web address, select the browsers you are interested in, then they will deliver you a screen shot of what it looks like in each one.
    It's not perfect by any means, but it does have its uses, especially in situations like this.

    To answer your question, your site looks good in IE10 & IE9, but in IE7 & IE8 the navigation positioning falls apart on a 17 inch monitor.

    I've made screen shots of each.
    You can download them here.

    Hope that helps.

  8. #8
    SitePoint Mentor NightStalker-DNS's Avatar
    Join Date
    Jul 2004
    Location
    Cape Town, South Africa
    Posts
    2,880
    Mentioned
    48 Post(s)
    Tagged
    0 Thread(s)
    Yes, it is looking better now, but still missing the rounded corners and some other styling elements. Attached is latest comparison

    IE.jpg

  9. #9
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    thank you very very much... I appreciate it.. I was going to go the library myself to test yesterday, but by the time I finished changing all padding & margins from rem to em it was too late... (the "real" site is three pages that look like the test page, with a lot more content of course...;-)

    I don't care about the rounded corners, just as long as it looks decent in IE7/8 (most users don't use those crappy browsers anyway... I suspect that literally every day more users are abandoning the old IE's...)

    I think it's interesting the buttons work in IE9, since my understanding is IE9 does not support gradients, and I did imgs for the buttons only for IE7/8..

    thank you very much, Pullo, for the screenshots, that's very useful (I can test on IE only on big desktop monitors in the library... I guess I need to remember to resize the browser window when I'm there...;-)
    I will certainly take a look at Browser Shots... Ralph, who has also helped me a lot on this forum, recommended some thing the other day on which I can run IE on my mac, but my mac is so slow now I don't know if in addition to running FF, Chrome, & DW at the same time I can also run IE's....;-)

    and thank you to Nightstalker too.... everyone's help is very much appreciated...

  10. #10
    Barefoot on the Moon! silver trophy Force Flow's Avatar
    Join Date
    Jul 2003
    Location
    Northeastern USA
    Posts
    4,615
    Mentioned
    56 Post(s)
    Tagged
    1 Thread(s)
    Try this for IE testing: http://my-debugbar.com/wiki/IETester/HomePage

    Note that it's not 100% perfect. Some javascript stuff doesn't always work, and png transparency fixes for older IE engines don't work.
    Visit The Blog | Follow On Twitter
    301tool 1.1.5 - URL redirector & shortener (PHP/MySQL)
    Can be hosted on and utilize your own domain

  11. #11
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Pullo,

    when I go here, http://browsershots.org/http://mayac...est_pg_ie.html

    after selecting MSIE7, I don't see a screenshot.. only an animated ad to dl Chrome....

    (it says "Your screenshots will appear here when they are uploaded".... ???) )


    thank you....

  12. #12
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    thank you ForceFlow.. IETester app app only runs in Windows machines......

  13. #13
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    never mind... I see how it works now....:-) thanks again..

    this is a lot better than nothing....

  14. #14
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,996
    Mentioned
    219 Post(s)
    Tagged
    12 Thread(s)
    Quote Originally Posted by maya90 View Post
    never mind... I see how it works now....:-) thanks again..

    this is a lot better than nothing....
    No problem

  15. #15
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    just came back from the library... still can't get the nav to work in IE7...
    http://mayacove.com/dev/rd_res/test_pg_ie.html

    it still looks messed up in narrow window width.. even though I changed the width of the nav ul's to practically the same as the wrapper right beneath it...
    (wrapper is 70, nav ul's are 65%)

    in IE8 the buttons look ok but it looks, from looking at the IE firebug, that it's loading the gradients... I don't see the img-bg in IE firebug... how can that be? I thought gradients don't work in IE.. not even in IE9...

    this is exhausting and frustrating.. I have realized the only way you can do responsive development properly is at work, where you can test in IE and all the devices.. at home on your own it's very difficult.... I feel for freelance folks who work at home now.. how do they do it?

    I will bring my laptop to the library this afternoon, hopefully I can work with my laptop beside me, they do have wifi access for your own machine, hopefully they will let me work on their machines and my laptop at the same time (they might be a bit paranoid about that..)

    again, thank you to everyone for your help...



    (PS: and I haven't even tested at all on Android or Windows devices, only iPhone and iPad (iPad in the simulator only.. you can't even scroll to the bottom of the page with it...)

  16. #16
    SitePoint Guru
    Join Date
    Jun 2009
    Posts
    825
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    ok, I can't test on Browser Shots anymore...
    these guys make it DEFAULT to a million browsers being selected, so if ONCE by mistake you request a g'zillion screenshots b/c you forget to deselect all browsers.. that's it.. they force you to create an account, which of course they do on purpose, no doubt...

    so I created an account, but when clicked on link in email to activate, I landed on a page that said "WRONG LINK, CAN'T ACTIVATE" or something like that.. I created a another acct, with a another email address, but I never received the activation link.... well, you know what they say... if it sounds too good to be true.....;-)

    but I managed to make a screenshot of the last one..
    http://mayacove.com/dev/rd_res/ie7.gif

    that was a width of 78% for the nav, why is it wider than other element, which is 70%?/

    this is not a problem, even in IE8... so here I am, stuck w/o being able to pub my site b/c of this persistent IE7 prob....:-(

    again, thank you very much to everyone for your help....


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •