SitePoint Sponsor

User Tag List

Results 1 to 23 of 23
  1. #1
    SitePoint Member
    Join Date
    Apr 2003
    Location
    sydney
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry could not run asp file on my webserver

    Hello!
    I am new to ASP. I am using windows 2000 server with IIS already install.
    I have copied test.asp file to wwwroot directory and
    tried to run it but it did not work ..and i gave me this error msg.

    http://localhost/test.asp
    or
    http://127.0.0.1/test.asp
    or
    http://my_server_name_here/test.asp

    The page cannot be displayed
    There is a problem with the page you are trying to reach and it cannot be displayed.
    HTTP 500 - Internal server error
    Internet Explorer

    I have even tried to run the iisstart.asp and localstart.asp which already
    exist at wwroot directory when IIS is installed.However, it still could not work.

    Does anyone know why ?
    I how do i know that the webserver and ASP engine is working properly.

    Thanks
    Last edited by http; Sep 20, 2007 at 20:27.

  2. #2
    ********* User Jmi's Avatar
    Join Date
    Dec 2002
    Location
    Australia
    Posts
    221
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    a couple of checks (though it may sound stupid)
    1. make sure u start the default web site.
    2. u running a personal firewall?
    3. did u changed the security rights on the wwwroot. If so, make sure u got IUSR_<machinename> given read permissions at least
    4. go to IIS -- > <machinename> --> Default Website --> properties --> IP Address

    see if its "All Unassigned" or 127.0.0.1 or the IP address of ur machine (if its static)

    these are some checks..
    Signature not found.

  3. #3
    SitePoint Member
    Join Date
    Apr 2003
    Location
    sydney
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi Jmi ,
    1. default web site is started .
    2.i don't have personal firewall
    3. i check in property -> Home directory
    the read access and script source access are checked. I don't know how to check IUSR_<machinename> access permission.
    4. If I used "All Unassigned" and test with the
    http://localhost/test.asp -> same error msg
    IF i changed IP adress to :127.0.0.1 and test with
    http://127.0.0.1 -> same error msg
    If i changed to the IP address of my computer and test with
    http://ipaddress/test.asp i have error access denied. even with the index.html
    at http://ipadress/index.html which normally can be access

  4. #4
    ********* User Jmi's Avatar
    Join Date
    Dec 2002
    Location
    Australia
    Posts
    221
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1.open up windows explorer
    2.navigate to c:\inetpub\wwwroot
    3. Properties --> Security
    4. By default, windows has "Everyone" group in it
    see if this group is in there.. (aint safe to have this but hey, its out of the context of ur problem"

    If "Everyone" is in there, make sure that "Read & Execute", "Read", "List Folder Contents" are checked

    If its not there,
    1. click "Add"
    2. Select ISUR_<machinename> (where <machinename> is ur computer name eg. my pc is call Pandora thus its "IUSR_Pandora")
    3. has read access

    btw, care to post the test.asp?? it might be the asp page having an error.
    last and final.. if all else fails, remove iis and reinstall it again
    Signature not found.

  5. #5
    SitePoint Member
    Join Date
    Apr 2003
    Location
    sydney
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thanks Jmi

    I have checked it..there is Everyone group with "Read& Execute","Read","List folder contents" are checked.
    To make sure I also add the ISUR_<mymachinename> in and this has read access.

    However, I still have same error msg

    Here is the test.asp that i copied from the internet

    <html>
    <head><title>My first ASP page</title>
    </head>
    <body>
    <p>The current date is <%=Date%>.</p>
    </body>
    </html>

    Also, the iisstart.asp and localstart.asp that already there when i installed IIS gave me the same error msg when i try to execute

  6. #6
    SitePoint Member
    Join Date
    Apr 2003
    Location
    sydney
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hold on
    I have HTTP 500 - Internal server error
    Internet Explorer
    The page cannot be displayed
    There is a problem with the page you are trying to reach and it cannot be displayed.

    NOT the HTTP 403 Access Denied error

  7. #7
    SitePoint Member
    Join Date
    Apr 2003
    Location
    sydney
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Here is the details of error msg i got from Event Viewer
    In system log
    Event Type: Error
    Event Source: DCOM
    Event Category: None
    Event ID: 10004
    Date: 24/04/2003
    Time: 5:20:08 PM
    User: N/A
    Computer: SHQNTS03
    Description:
    DCOM got error "The referenced account is currently locked out and may not be logged on to. " and was unable to logon .\IWAM_SHQNTS03 in order to run the server:
    {3D14228D-FBE1-11D0-995D-00C04FD919C1}

    In security log

    Event Type: Failure Audit
    Event Source: Security
    Event Category: Account Logon
    Event ID: 681
    Date: 24/04/2003
    Time: 5:20:06 PM
    User: NT AUTHORITY\SYSTEM
    Computer: SHQNTS03
    Description:
    The logon to account: IUSR_SHQNTS03
    by: MICROSOFT_AUTHENTICATION_PACKAGE_V1_0
    from workstation: SHQNTS03
    failed. The error code was: 3221226036

    Any idea how to show this?

  8. #8
    ********* User Jmi's Avatar
    Join Date
    Dec 2002
    Location
    Australia
    Posts
    221
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmm

    looks like u got a security problem..
    IIS --> SHQNTS03 --> Properties --> Edit (WWW Services) --> Directory Security --> Edit (Anonymous access....)

    see if anonymouse access is checked.
    then press Edit
    should have IUSR_SHQNTS03 on the list and also "Let IIS Control Password" checked.

    I really hope it helps till someone can answer u. I am just giving it a go, hope u dun mind
    Signature not found.

  9. #9
    ********* User Jmi's Avatar
    Join Date
    Dec 2002
    Location
    Australia
    Posts
    221
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    got this off msdn
    IIS 5.0 provides a utility script named synchiwam.vbs to update the launching identity of all IIS COM+ application packages that run out of process. The synciwam.vbs script can be found in the \Inetpub\AdminScripts directory and can be run using cscript or wscript
    Signature not found.

  10. #10
    SitePoint Member
    Join Date
    Apr 2003
    Location
    sydney
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Jmi,
    I have not try to follow your instructions, but
    thank so much for your help.

  11. #11
    The doctor is in... silver trophy MarcusJT's Avatar
    Join Date
    Jan 2002
    Location
    London
    Posts
    3,509
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Please don't post problems in this forum - that's not why it's here... move in progress...
    MarcusJT
    - former ASP web developer / former SPF "ASP Guru"
    - *very* old blog with some useful ASP code

    - Please think, Google, and search these forums before posting!

  12. #12
    The doctor is in... silver trophy MarcusJT's Avatar
    Join Date
    Jan 2002
    Location
    London
    Posts
    3,509
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    PS - I think you'll find that the Windows user account called "Guest" is disabled. If not, check that the two IUSR_ accounts are enabled too...
    MarcusJT
    - former ASP web developer / former SPF "ASP Guru"
    - *very* old blog with some useful ASP code

    - Please think, Google, and search these forums before posting!

  13. #13
    SitePoint Addict MadDog's Avatar
    Join Date
    Aug 2002
    Location
    Oregon, USA
    Posts
    247
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    the HTTP 500 is error an error for asp when the script fails. You need to turn off "Show Friendly HTTP Error Messages" in IE.

    Theres a tutorial here on how to do it, http://www.maddogs-asp.com/show_tuto...TutorialID=167

    After you do that you will get an error message. Post that and i might be able to help you
    Drew Gauderman
    ASP/MSSQL/AJAX-Javascript/HTML/CSS Coder
    iPortalX The most secure FREE ASP portal!

  14. #14
    Life is short. Be happy today! silver trophybronze trophy Sagewing's Avatar
    Join Date
    Apr 2003
    Location
    Denver, Phang-Nga, Thailand
    Posts
    4,379
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    just get your IUSR accounts read/write/execute privs on that file/directory and it will be ok.

    mind the groups and inheritance of the permissions carefully since that is a major gotcha here. this is a classic asp config issue with lots of info on it..
    The fewer our wants, the nearer we resemble the gods. Socrates

    SAGEWING LLC - QUALITY WEB AND MOBILE APPS. PREMIUM OUTSOURCING SERVICES.
    Twitter | LinkedIn | Facebook | Google+

  15. #15
    SitePoint Member
    Join Date
    Apr 2003
    Location
    sydney
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Here is the error msg i got from the web browser
    Server Application Error
    The server has encountered an error while loading an application during the processing of your request. Please refer to the event log for more detail information. Please contact the server administrator for assistance.

    when i looked into the event viewer i got the error msg posted before.

  16. #16
    SitePoint Member
    Join Date
    Apr 2003
    Location
    sydney
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    JMi,

    I checked everyhting you told me...
    It still give the same error msg

  17. #17
    Life is short. Be happy today! silver trophybronze trophy Sagewing's Avatar
    Join Date
    Apr 2003
    Location
    Denver, Phang-Nga, Thailand
    Posts
    4,379
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Concentrate on the permissions issue, I think.

    Check the security on the directory that contains the file. Find the IUSR users and make sure that both of them have full permissions on that directory.
    The fewer our wants, the nearer we resemble the gods. Socrates

    SAGEWING LLC - QUALITY WEB AND MOBILE APPS. PREMIUM OUTSOURCING SERVICES.
    Twitter | LinkedIn | Facebook | Google+

  18. #18
    Alt+F4= User Control ;-) rabmurdy's Avatar
    Join Date
    Mar 2002
    Location
    Ecosse
    Posts
    398
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have you bothered to check and see if ASP is installed on the web site you are trying to run it from?

    If not: right click the web site in IIS manager and choose options. Click configuration and see if there is a mapping for .asp files.

    Also check the documents tab and ensure that the .asp extension is enabled.

    Just some ideas to try.
    "If something is too hard,give it up. The moral my boy is too never try anything"
    "Just because I don't care doesn't mean I don't understand"

  19. #19
    Life is short. Be happy today! silver trophybronze trophy Sagewing's Avatar
    Join Date
    Apr 2003
    Location
    Denver, Phang-Nga, Thailand
    Posts
    4,379
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If it wasn't, I think the webserver would have just sent the asp file to the browser as is... unprocessed..
    The fewer our wants, the nearer we resemble the gods. Socrates

    SAGEWING LLC - QUALITY WEB AND MOBILE APPS. PREMIUM OUTSOURCING SERVICES.
    Twitter | LinkedIn | Facebook | Google+

  20. #20
    ********* User Jmi's Avatar
    Join Date
    Dec 2002
    Location
    Australia
    Posts
    221
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I cant really make out wat is wrong.
    how abt uninstall IIS, reboot and reinstalling it again.
    if the default iisstart dun work, its hard to make any other web work as well.
    Signature not found.

  21. #21
    ********* User Jmi's Avatar
    Join Date
    Dec 2002
    Location
    Australia
    Posts
    221
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    From that event error u got from the log, i made a check on the web and most places they suggested running the "synchiwam.vbs" file located in the Adminscripts folder. It worked for many of them. Anyways, try a reinstallation and make sure iisstart works.

    sorry i couldnt be of much help
    Signature not found.

  22. #22
    Santos L Halper Zenith's Avatar
    Join Date
    May 2002
    Location
    Finland
    Posts
    641
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try doing this:

    Control Panel -> Administrative Tools -> Internet Information Services.

    Click "default web site" with right mouse button, select "New" -> virtual directory.

    Give the alias and select some directory under your X:/inetpub/wwwroot. And then: make sure you got checked "Read" and "Run Scripts" and "Execute" boxes.

    I think you haven't given permissions to run scripts. Also, if you use IE make sure you have unchecked "show friendly error messages" from Tools -> Internet Options -> Advanced. If you have friendly errors checked you never get "real" error messages.

    -Z-

  23. #23
    Non-Member
    Join Date
    May 2003
    Location
    Mtl.
    Posts
    107
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    too bad nobody seen this... heres what he wrote ISUR_<mymachinename>
    --^

    seems wrong doesnt it


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •