SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Zealot thespian's Avatar
    Join Date
    Sep 2000
    Location
    South Africa
    Posts
    186
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi there, I hope someone can help me with what I am sure is a simple problem that I cannot for the life of me get sorted out. I am obviously doing something very stupid!

    I code all my HTML in a "NoteBook" type of editor. When I use the extension .htm or .html and I double-click on the file later, it opens in IE (as I would expect it to). When however I save the file with a .asp extension and double-click on it later, it opens up in Adobe Photoshop.

    I have gone into the folder options from Windows Explorer but I cannot find where the type .asp is associated with any program. If I try to associate it with IE, I get an error saying that is already asigned to some sort of Adobe Photoshop Table file or other.

    I am asking the question in this forum since there seems to be a number of Photoshop experts hanging about here.

    Oh yes, by the way, I do not as yet have Active Server Pages loaded on my computer.

    Many Thanx...
    Bill Conté [Protected by Psalm 91]
    Web Mechanix
    Growing OLD is Mandatory - Growing UP is Optional!

  2. #2
    SitePoint Guru
    Join Date
    Dec 1999
    Location
    Southampton, Hants, UK
    Posts
    672
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had this problem as well, not sure how I managed to fix it, but now th files open in notepad.
    oh yeah I remember now

    Right Click on the file with Shift key held down, goto 'open with', then find the program you want to open it with, then click the text box which says 'use this program all the time' or something like that

  3. #3
    SitePoint Zealot thespian's Avatar
    Join Date
    Sep 2000
    Location
    South Africa
    Posts
    186
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanx Daniel.

    It worked a charm! Now I must just work out a way to change the file's icon.

    Many Thanx Once Again
    Bill Conté [Protected by Psalm 91]
    Web Mechanix
    Growing OLD is Mandatory - Growing UP is Optional!

  4. #4
    SitePoint Wizard jonese's Avatar
    Join Date
    Jul 1999
    Location
    Powder Springs GA (Atlanta)
    Posts
    1,238
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you will need to change the propertise for that extension. you can usually find it inthe view properties or something like that. not sure where it is exactly on your machine.

    what version of windows are you running...

  5. #5
    SitePoint Wizard jonese's Avatar
    Join Date
    Jul 1999
    Location
    Powder Springs GA (Atlanta)
    Posts
    1,238
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok here is a fix for the PS viewing ASP files...

    open up "my documents".

    click on view then down to "folder options."

    Click on the "file types" folder

    In the "registered File Types" list you will need to scroll down to the "ASP File" option.

    Once you have found the ASP File option you will double click it and it will open the "Edit File Type" window for you.

    You should see 2 options. an "open" and an "edit with" option.

    You want to change the open option to IE (or NN)

    You want to change the edit with option to your current proram for editing ASP programs (notepad, DW, FP)

    once done just hit ok and close out the windows. Then test. it should open in IE (or NN) and you can edit it with the program you choose.


    feel free to contact me for more information.

  6. #6
    SitePoint Zealot thespian's Avatar
    Join Date
    Sep 2000
    Location
    South Africa
    Posts
    186
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Eric,

    Many thanx for the reply. Having been around MS for a while now, your solution was the first that I tried. Now here is the problem.

    When looking through the VIEW | OPTIONS | FILE TYPES, there is no reference to the ASP files at all whatsoever (unless I am blind or they have coded it in morse). When I attempt to create a "New File Type" for the .asp extension, I get the following message: The extension '.asp' is already in use by the file type 'Photoshop.SepTablesFile'. Choose another extension. Needless to say there is no reference to such a file type in VIEW | OPTIONS | FILE TYPES. The only reference to anything to do with Photoshop mereley references '.psd' extensions.

    A final point - when listing the files (in Windows / NT Explorer) these files are described in the "Type" colum as being "ASP files" (The normal way of describing files not allocated to a specific type) but the icon is a "Photoshop Graphic Image".

    This situation applies to both Photoshop 5 and 5.5 on both Windows NT (IE4) and Windows 98 (IE5.5).

    I am really stumped with this one.
    Bill Conté [Protected by Psalm 91]
    Web Mechanix
    Growing OLD is Mandatory - Growing UP is Optional!

  7. #7
    SitePoint Wizard jonese's Avatar
    Join Date
    Jul 1999
    Location
    Powder Springs GA (Atlanta)
    Posts
    1,238
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    try reinstalling PS 5.5 and then install DW or another editor. this might find and fix the problem for you. otherwise i'm clueless.

  8. #8
    SitePoint Guru
    Join Date
    Dec 1999
    Location
    Southampton, Hants, UK
    Posts
    672
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yeah - I still have the icons that i don't want - I gave up trying to change them!

  9. #9
    SitePoint Zealot thespian's Avatar
    Join Date
    Sep 2000
    Location
    South Africa
    Posts
    186
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Daniel - I'm with you - I have also given up. I am however going to try and see if I can get an answer out of Adobe. I will post the result here.
    Bill Conté [Protected by Psalm 91]
    Web Mechanix
    Growing OLD is Mandatory - Growing UP is Optional!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •