SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Dec 2011
    Northern Ireland
    0 Post(s)
    0 Thread(s)

    Major problem - Need serious help :(

    Basically the problem is that every time I launch MAMP PRO and start the servers, when the MySQL server attempts to start I get this message...

    Error message:
    /Applications/MAMP/Library/bin/mysqlcheck: Got error: 1045: Access denied for user 'root'@'localhost' (using password: YES) when trying to connect
    Then I try out of curiosity the webstart button to attempt to open the MAMP start page... and I get this error

    Error: Could not connect to MySQL server!
    Finally I use the "Launch PhpMyAdmin Button".. and I get this error

    MySQL said: 
    #1045 - Access denied for user 'root'@'localhost' (using password: YES) 
    Unknown language: en-iso-8859-1.
    phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.
    This all seems to have happened when I stupidly tried to create a new user in PHP myadmin and I think I have entirely messed up the "root" account - However with this kind of topic this is as far as my knowledge goes... I am baffled..

    How can I restore everything to normal so that I can access the MAMP start page, phpmyadmin etc ??? Ive tried completely uninstalling MAMP/MAMP PRO, nothing..

    I've looked high and low on Google and all I can find are pages of words that are double dutch to me... I dont understand what the problem is basically. This will probably sound really stupid to alot of you but I really do not know what to do here I would just like MAMP PRO to work again.. when ive tried to read all of these "fixes" they talk about the root account, but since i edited the root account in phpmyadmin - what account are they talking about, a database account, the root account of the computer itself?? I really don't even care enough to know all I want is it to work again ... im SO confused..

    Can someone please explain to me in laymens terms whats happened here and how I can fix it? I would be so greatful...

  2. #2
    SitePoint Member
    Join Date
    Apr 2013
    0 Post(s)
    0 Thread(s)
    try this.

    shutdown mysql.
    edit mysql server's my.ini or my.cnf - add option below


    startup mysql, u shld be able to login as root without password check.

    update mysql.user set password=password("newpassword") where user="root"

    revert the skip-grant-tables and reboot mysql


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts