I am trying to sort out why a server I'm working with, running in a virtual machine, will not respond by name. I know the OS overall recognizes the name cause I have a putty session to the vm by name. So it has to be the vhost config.

Ran: sudo apache2ctl -t -D DUMP_VHOSTS
Results:
Code:
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:443                  is a NameVirtualHost
         default server newturkey.trollandtoad.com (/etc/apache2/sites-enabled/trollandtoad-ssl:3)
         port 443 namevhost newturkey.trollandtoad.com (/etc/apache2/sites-enabled/trollandtoad-ssl:3)
*:80                   is a NameVirtualHost
         default server newturkey.trollandtoad.com (/etc/apache2/sites-enabled/trollandtoad:2)
         port 80 namevhost newturkey.trollandtoad.com (/etc/apache2/sites-enabled/trollandtoad:2)
That seems ok. I'm running out of ideas. Help?