SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Enthusiast
    Join Date
    Mar 2013
    Posts
    63
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Menu wont line up in IE7

    Hi Guys,

    my site looks fine in firefox etc. but a few things aren't quite right in IE.

    In IE7 the menu doesn't line up properly, anyone got any ideas why this is and a quick fix? Cheers!
    www.cotswoldbells.co.uk

  2. #2
    SitePoint Mentor bronze trophy
    John_Betong's Avatar
    Join Date
    Aug 2005
    Location
    City of Angels
    Posts
    1,806
    Mentioned
    73 Post(s)
    Tagged
    6 Thread(s)
    Quote Originally Posted by ac1986 View Post
    Hi Guys,

    my site looks fine in firefox etc. but a few things aren't quite right in IE.

    In IE7 the menu doesn't line up properly, anyone got any ideas why this is and a quick fix? Cheers!
    www.cotswoldbells.co.uk
    Check out these errors:

    1. line 438 column 5 - Error: Stray end tag ul.

    2. line 440 column 7 - Error: End tag div seen, but there were open elements.

    3. line 435 column 41 - Error: Unclosed element footer.

    4. line 441 column 9 - Error: Stray end tag footer.

    5. line 444 column 6 - Error: Stray end tag div.

    Once errors eliminated and page validated your page will no doubt display differently

    Check out:
    "http://validator.w3.org/check?uri=http%3A%2F%2Fwww.cotswoldbells.co.uk%2F&charset=%28detect+automatically%29&doctype=Inline&group=0"
    Last edited by John_Betong; Apr 18, 2013 at 08:20. Reason: added w3.org validation link

  3. #3
    SitePoint Enthusiast
    Join Date
    Mar 2013
    Posts
    63
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm not really sure I know how to fix these :S

  4. #4
    SitePoint Enthusiast
    Join Date
    Mar 2013
    Posts
    63
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok, I managed to fix most of them!

    One that is messing up the alignment for the buttons is from a plugin:

    Error Line 41, Column 180: Bad value for attribute media on element link: Media query ended prematurely.

    …/ie-css3-support/css/custom-style.css?ver=20121910' type='text/css' media='' />

    Any idea how to fix this one? Or even where to edit it? Cheers

  5. #5
    SitePoint Mentor bronze trophy
    John_Betong's Avatar
    Join Date
    Aug 2005
    Location
    City of Angels
    Posts
    1,806
    Mentioned
    73 Post(s)
    Tagged
    6 Thread(s)
    Quote Originally Posted by ac1986 View Post
    Ok, I managed to fix most of them!

    One that is messing up the alignment for the buttons is from a plugin:

    Error Line 41, Column 180: Bad value for attribute media on element link: Media query ended prematurely.

    …/ie-css3-support/css/custom-style.css?ver=20121910' type='text/css' media='' />

    Any idea how to fix this one? Or even where to edit it? Cheers
    Try adding "screen" to the empty media parameter:

    HTML Code:
    
        <link rel='stylesheet' id='custom-style-css' href='http://www.cotswoldbells.co.uk/wp-content/plugins/ie-css3-support/css/custom-style.css?ver=20121910' type='text/css' media='screen' />
        

    To not only help your SEO Brownie Points but also to squash the " An img element must have an alt attribute..." errors:

    HTML Code:
    <img src='...' alt="Replace with SEO catch phrase" />

  6. #6
    SitePoint Enthusiast
    Join Date
    Mar 2013
    Posts
    63
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Where abouts do I find this code so that I can change it? Cheers

  7. #7
    SitePoint Mentor bronze trophy
    John_Betong's Avatar
    Join Date
    Aug 2005
    Location
    City of Angels
    Posts
    1,806
    Mentioned
    73 Post(s)
    Tagged
    6 Thread(s)
    Quote Originally Posted by ac1986 View Post
    Where abouts do I find this code so that I can change it? Cheers

    With your text-editor search for the unique identifierm id="custom-style-css". There should be only one unique occurrence.

    Replace the following line:
    HTML Code:
     
    <link rel='stylesheet' id='custom-style-css' href='http://www.cotswoldbells.co.uk/wp-content/plugins/ie-css3-support/css/custom-style.css?ver=20121910' type='text/css' media='screen' />
        

  8. #8
    SitePoint Enthusiast
    Join Date
    Mar 2013
    Posts
    63
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    But where abouts do I search that code in WP? I've looked for it in the plugin files with no luck?

  9. #9
    SitePoint Mentor bronze trophy
    John_Betong's Avatar
    Join Date
    Aug 2005
    Location
    City of Angels
    Posts
    1,806
    Mentioned
    73 Post(s)
    Tagged
    6 Thread(s)
    Quote Originally Posted by ac1986 View Post
    But where abouts do I search that code in WP? I've looked for it in the plugin files with no luck?
    My knowledge of Wordpress is limited and I do not know where to start looking for the relevant script.



    This thread is in the "CSS & Page Layout" Forum so I think it would be better if you requested the thread to be moved to the CMS & Wordpress" Forum.

    Only Administrators of the forum can move the thread and they can be found by opening the "CSS & Page Layout" Forum and selecting "Announcement: Meet the Design Team".


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •