SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Zealot bazzablue's Avatar
    Join Date
    Mar 2005
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Carousel not displaying images in Drupal

    A new client has recently transferred their web hosting to me with a view to a site redesign in the near future. The site is built on Drupal, a system I have no experience with.

    The changeover went fairly smoothly. The only issue we encountered was with images on the News stories and the home page carousel. We discovered a solution for the news story pictures here but not the carousel issue. The site in question is www.fyt.org.uk.

    I would be happy to past code as directed or allow FTP access if that would be helpful in solving the issue.

    Thanks in advance.
    Barry

    Snap Designs
    Creating good impressions online and in print

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,200
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    The carousel seems to be working fine to me (in Chrome at least). What browser are you checking this in, or what is the issue you are seeing?

  3. #3
    SitePoint Zealot bazzablue's Avatar
    Join Date
    Mar 2005
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The carousel works in that new items appear but the picture doesn't show on the first two items. These news items have been added to the site since the changeover.
    Barry

    Snap Designs
    Creating good impressions online and in print

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,200
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    It seems that the images simply aren't where they are meant to be. You could perhaps manually upload them to the folder where they should be.

  5. #5
    SitePoint Wizard bronze trophy
    Join Date
    Oct 2001
    Location
    Vancouver BC Canada
    Posts
    2,030
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Yeah, as ralph.m mentioned the images should be at: sites/default/files/imagecache/carousel/

    They should be as follows:

    • /sites/default/files/imagecache/carousel/STSPbooks.jpg
    • /sites/default/files/imagecache/carousel/DSC_0715.JPG
    • /sites/default/files/imagecache/carousel/Greenbelt workshop.jpg
    • /sites/default/files/imagecache/carousel/O4G Winter Small.jpg
    • /sites/default/files/imagecache/carousel/Terry Dunnell Web.jpg


    The last 3 images do work but going froward it might be a little more complicated than just putting the images in that folder because you're using imagecache which has probably been set up to resize and/or crop images on the fly to fit that particular size. Imagecache uploads the original and then saves as many variations of the original as you need in specific folders. There is probably an image "style" called carousel that has a specific width/length that that those are saved to. If you change the style, imagecache will reoptimize the images without needing to be re-uploaded.

    I would look at your system settings to make sure that imagecache is set up correctly and saving the images to the proper spot on the file system. It may be that the original images were not saved and may need to be re-uploaded.

    Andrew
    Andrew Wasson | www.lunadesign.org
    Principal / Internet Development


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •