SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Zealot
    Join Date
    Mar 2001
    Posts
    143
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Variables passed in the url once logged in

    Hello,
    I'm having trouble passing variables from the url once a user logs into a members only section of my website.

    Take this file name for example:
    download_manager_edit.php?ACTION=download&ID=2

    When I do login successfully, the page it redirects to is:
    download_manager_edit.php?ACTION=download

    The second variable in the URL (ID = 2) does not get passed.

    Any ideas as to why?
    Bardius

  2. #2
    pie??? PIE!!!! rsdl's Avatar
    Join Date
    May 2001
    Location
    Vancouver, BC Canada
    Posts
    502
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    instead of using & try using &. i'm guessing php thinks that &ID=2 is an html entity

    also, post the code that generates that link so that we can better solve your problem


    -rsdl
    Last edited by rsdl; Mar 30, 2003 at 15:55.

  3. #3
    SitePoint Zealot
    Join Date
    Mar 2001
    Posts
    143
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Your suggestion doesn't seem to work.

    There isn't any code that generates the link. In my I.E's address bar I just type in the url (download_manager_edit.php?ACTION=download&ID=2) and get told to login because its a members only area. If the login is successful (the first include file on the page checks this), then session variables are created and the rest of the page after the include loads. If it doesn't, then I have the login form show again and use exit; to bring an end to the page.
    Bardius

  4. #4
    SitePoint Zealot
    Join Date
    Mar 2001
    Posts
    143
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok I figured out what my problem was...
    Bardius

  5. #5
    pie??? PIE!!!! rsdl's Avatar
    Join Date
    May 2001
    Location
    Vancouver, BC Canada
    Posts
    502
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    and that was.....?
    was it a global variable progblem? e.g. $_GET['ID'];

    -rsdl


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •