SitePoint Sponsor

User Tag List

Results 1 to 6 of 6

Hybrid View

  1. #1
    SitePoint Enthusiast TheEngine's Avatar
    Join Date
    Sep 2003
    Location
    Sunnyvale Trailer Park
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Permalink Issue - I don't understand Permalinks!

    Hello,
    I'm trying to change my permalink structure from default "http://www.graphicengine.ca/?p=123" to custom structure using "/%postname%/" and after setting it to this, WordPress automatically selects the Post name option "http://www.graphicengine.ca/sample-post/". Basically I want my page name to be shown in the URL.

    When I test it out and click on my About Us page (http://www.graphicengine.ca/about-us/), I get 404 Not Found. When I go to my About Us page, it shows permalink: Permalink: http://www.graphicengine.ca/about-us/.

    Not sure how to fix or if need to do something to .htaccess. Of course if I revert back to original permalink default, links work. Also, just to note I'm using Yoast SEO.

    Any ideas how to fix?

    Thanks!

  2. #2
    SitePoint Member
    Join Date
    Apr 2013
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hope this link can help SEO Friendly URL Structure for Your WordPress

    For your current problem add this code to your .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  3. #3
    SitePoint Enthusiast TheEngine's Avatar
    Join Date
    Sep 2003
    Location
    Sunnyvale Trailer Park
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by plugins View Post
    hope this link can help SEO Friendly URL Structure for Your WordPress

    For your current problem add this code to your .htaccess file:

    Hi,
    I tried that code in my .htaccess, but it did not work. I've read the article you mentioned and have read several others, testing out different options but can't seem to get working properly and it seems like every article I read says something different. I've had to resort back to default for now.

    Would deleting and having WordPress rebuild the .htaccess file help? I'll keep trying to fix when I can find some time. Thanks.

  4. #4
    SitePoint Addict bronze trophy
    Join Date
    Mar 2013
    Location
    Oneonta, NY
    Posts
    307
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Theengine,

    When you log into your wordpress back end, go to your page (in this case your about us page) and at the top above where you write your content, you should see your permalink. Click the edit button for this and it will allow you to edit the permalink.

    You may also find some useful info here,

    http://codex.wordpress.org/Using_Permalinks

    Best,

    Shawn

  5. #5
    SitePoint Enthusiast TheEngine's Avatar
    Join Date
    Sep 2003
    Location
    Sunnyvale Trailer Park
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi Shawn, when I change my permalink structure to /%postname%/, it changes my permalink on my aboutus page to http://www.graphicengine.ca/about-us/ , so think that is how it should appear, but when I test it out I still get the page not found error. Thanks for the link, I'll take a look at that again.
    _______________________________________________________
    Graphic Engine Design

  6. #6
    SitePoint Member
    Join Date
    Apr 2013
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If you still have the problem Please Pm me, i will try to solve your problem


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •