SitePoint Sponsor

User Tag List

Results 1 to 8 of 8

Hybrid View

  1. #1
    SitePoint Evangelist cgacfox's Avatar
    Join Date
    Feb 2005
    Location
    Colorful Colorado
    Posts
    412
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    rel and rev attribute problems

    I am incorporating Magic Magnifier Plus for my client's site. The rev and rel that the designers used is not valid and I am getting errors when validating the code. Is there any way to correct this without screwing up how everything works? The site is http://foxdenwebsolutions.com/discri..._necklace.html. Please ignore the "shoe" reference....this is for jewelry and I am only making sure it works before changing out the image names. Also can anyone tell me how to place a border around the small thumbnail images? I want it to be the same as the larger image but not as wide. This seems to be using Flash and I was able to get one around the larger images but something seems funky with the thumbnails. Thanks.

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,590
    Mentioned
    411 Post(s)
    Tagged
    6 Thread(s)
    If the attributes work, don't worry about validation, as that's just a guide.

    You could do thumbnail borders like this:

    Code:
    .fivecol a img {border: 5px solid #6E8A95;}

  3. #3
    SitePoint Evangelist cgacfox's Avatar
    Join Date
    Feb 2005
    Location
    Colorful Colorado
    Posts
    412
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Thanks Ralph. I actually changed the .fivecol to .fivecal detail so the image on the necklaces page does not have a border on it. It works.

    I don't like having errors in my code from the validation and I understand what you are saying, but is there any way to change them so the validation comes back clean?

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,590
    Mentioned
    411 Post(s)
    Tagged
    6 Thread(s)
    rel="" is normally OK to use. I'm not sure what the rev="" is for, but I wonder if you need it at all. What happens if you delete it?

  5. #5
    SitePoint Evangelist cgacfox's Avatar
    Join Date
    Feb 2005
    Location
    Colorful Colorado
    Posts
    412
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Removed both, tested. Removed rel, tested, Removed rev, tested. Looks like they are both needed to work with the image change hover feature and the zoom feature. GRRRRR. Well my code won't be completely error free. Does not make me happy!

  6. #6
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,590
    Mentioned
    411 Post(s)
    Tagged
    6 Thread(s)
    Rel is common, so I don't know why it would throw errors, but the rev is weird, as I can't see it being called in the script at all. O well, obvioulsy a reason. The validation issue is a non-issue, though. If it works, it's OK.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •