First post on this forum. I created a site a while back for a client using Zencart 1.2 and I have a need to show it as a functioning site, though it is no longer live. I have all the original files and I'm confident that I can't just plug them into a newer version of Zencart. I tried to install 1.2 and got quite far, however at the end I got multiple versions of the following error:

"Deprecated: Function ereg_replace() is deprecated in /MY_DOMAIN/zc_install/includes/functions/general.php on line 298"
and
"Warning: Cannot modify header information - headers already sent by (output started at /MY_DOMAIN/zc_install/includes/functions/general.php:298) in /MY_DOMAIN/zc_install/includes/modules/pages/store_setup/header_php.php on line 91"

My host is using phpMyAdmin 3.5.5, MySQL 5.1.68 and Cpanel11 (not sure what version of PHP)

Is there any way to run Zencart 1.2 on the new software? If not, is there a testing environment available?

Thanks.