SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Member
    Join Date
    Mar 2013
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Menu NOT working on mobile wordpress site - Sorry if this is an old question

    Hi all,

    The website I am working on is:

    http://www.rjmforestry.co.uk

    I also am trying to have a staff intranet on the website which will be password protected.

    http://www.rjmforestry.co.uk/livingthedream (password to login is Hottinger - nothing particularly secret on there though so feel fre to log in!)

    I am having an issue with menus when I view this on a mobile phone. I can access the site just fine, but the menu button appears in the centre of the homepage, but when i click on it, nothing happens. The button appears to be "pressed" but no menus drop down.

    I apologise if this is a common issue and I am just being a bit stupid but can someone offer me some kind of guidance as to how I can sort this problem out?

    I have tried this with different phones - iphone, android etc. But still the same problem.

    When I view this on my mac, the menus are working just fine.

    Any help would be much appreciated,

    Thank you

    Claire

    ps using the twentytwelve theme

  2. #2
    SitePoint Evangelist snecz's Avatar
    Join Date
    Mar 2007
    Location
    Warsaw, Poland
    Posts
    429
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi, Maybe it's because of the slider. Try disable it and see.
    Warsaw - the city that survived its own death.
    EMM8 - Profesjonalne Strony Internetowe
    Projektowanie Stron WWW

  3. #3
    SitePoint Member
    Join Date
    Mar 2013
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I dont have a slider on the intranet (www.rjmforestry.co.uk/livingthedream) so dont think it's going to be that. But will try it.

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,171
    Mentioned
    454 Post(s)
    Tagged
    8 Thread(s)
    When the menu button is clicked, it is meant to trigger some JS that is obviously not working. Presumably it comes with the theme (though I can't see which script it is). What did you do to the theme when you installed it? Did you delete or disable anything?

    If you look at the twentytwelve demo site, there is a navigation.js script that has the code you need. See at the bottom of this page:

    http://s1.wp.com/_static/??/wp-conte...?m=1354656609j

    If you link that page to your site, the toggle button works again.

  5. #5
    SitePoint Member
    Join Date
    Mar 2013
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for your help every body. I disabled all themes and enables twentyeleven theme instead of twenty twelve. It works fine now. Conclusion... I messed with something I shouldn't have done.

    It's probably worth me saying, I wouldn't have messed with the script of a theme unless a plugin had talked me through making changes.

    Ralph, thanks for your comment. I think you are offering a solution, but although embarrassing to own up to, the truth is I don't understand what you are suggesting I do. I'd be more than willing to try this - but could you offer me idiot proof instructions?

    I'm so fed up and I'm such a novice that i'm going to carry on with twentyelevn and play around with it to make it look how I want it to look.

    I must have screwed up the theme or a plug in may have done it. I installed and activated a number of plug ins although I wasn't actually using them.

    For your info - if anyone is interested in investigating this further, the plug ins I had activated but wasn't taking advantage of were:

    Contact Form 7
    Buddypress
    Custom Community
    Jquery Validation For Contact Form 7
    Multisite User Managemen
    vSlider
    WPNewCarousels

    Bleh. Onwards with the website... after this glass of wine and a few hours sleep me thinks.

    Seriously, thanks for your help. I'm learning!

    Claire

  6. #6
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,171
    Mentioned
    454 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by clairehottie View Post
    Ralph, thanks for your comment. I think you are offering a solution, but although embarrassing to own up to, the truth is I don't understand what you are suggesting I do. I'd be more than willing to try this - but could you offer me idiot proof instructions?
    No, don't worry about it. All I was doing is noting that with the original code, the button works, which you've found by going back to the original. What I suggested wasn't a fix as such, but just a way of demonstrating that something was missing from your code.

    Glad you are back up and running.

    When I first got interested in web design, I stumbled around in the dark for a while, then bit the bullet and did some study to get at least the foundations in place. That was very helpful. Now I stumble around in the light.

  7. #7
    SitePoint Member
    Join Date
    Mar 2013
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Cool

    Very wise move re training. I'm considering booking some training. In the meantime, it's great that I can ask for free of charge help from kind folk on this forum, whilst I continue to feel around in the dark!

    Thank you again, Ralph and Snecz.

  8. #8
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,171
    Mentioned
    454 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by clairehottie View Post
    In the meantime, it's great that I can ask for free of charge help from kind folk on this forum ...
    Definitely. That's what we are here for.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •